<!DOCTYPE html>
<html lang="en-US"
	prefix="og: https://ogp.me/ns#"  class="no-js">
<head>
	<meta charset="UTF-8">
	        <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />
    	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="https://etvnews.com/xmlrpc.php">
	<!--[if lt IE 9]>
	<script src="https://etvnews.com/wp-content/themes/-new-newsplus/js/html5.js"></script>
	<![endif]-->
	
		<!-- All in One SEO 4.1.2.2 -->
		<title>Frank Sacco - ETV News</title>
		<meta name="description" content="October 9, 1945 – August 7, 2021 To view the entire obituary, please click here. "/>
		<link rel="canonical" href="https://etvnews.com/frank-sacco/" />
		<meta property="og:site_name" content="ETV News - Castle Country&#039;s Finest News Source" />
		<meta property="og:type" content="article" />
		<meta property="og:title" content="Frank Sacco - ETV News" />
		<meta property="og:description" content="October 9, 1945 – August 7, 2021 To view the entire obituary, please click here. " />
		<meta property="og:url" content="https://etvnews.com/frank-sacco/" />
		<meta property="og:image" content="https://etvnews.com/wp-content/uploads/2021/08/Frank-Sacco.jpeg" />
		<meta property="og:image:secure_url" content="https://etvnews.com/wp-content/uploads/2021/08/Frank-Sacco.jpeg" />
		<meta property="og:image:width" content="400" />
		<meta property="og:image:height" content="862" />
		<meta property="article:published_time" content="2021-08-09T17:40:01Z" />
		<meta property="article:modified_time" content="2021-08-09T17:40:01Z" />
		<meta property="article:publisher" content="https://www.facebook.com/etvten" />
		<meta name="twitter:card" content="summary" />
		<meta name="twitter:domain" content="etvnews.com" />
		<meta name="twitter:title" content="Frank Sacco - ETV News" />
		<meta name="twitter:description" content="October 9, 1945 – August 7, 2021 To view the entire obituary, please click here. " />
		<meta name="twitter:image" content="https://etvnews.com/wp-content/uploads/2021/08/Frank-Sacco.jpeg" />
		<script type="application/ld+json" class="aioseo-schema">
			{"@context":"https:\/\/schema.org","@graph":[{"@type":"WebSite","@id":"https:\/\/etvnews.com\/#website","url":"https:\/\/etvnews.com\/","name":"ETV News","description":"Castle Country's Finest News Source","publisher":{"@id":"https:\/\/etvnews.com\/#organization"}},{"@type":"Organization","@id":"https:\/\/etvnews.com\/#organization","name":"ETV News","url":"https:\/\/etvnews.com\/","sameAs":["https:\/\/www.facebook.com\/etvten"]},{"@type":"BreadcrumbList","@id":"https:\/\/etvnews.com\/frank-sacco\/#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/etvnews.com\/#listItem","position":"1","item":{"@type":"WebPage","@id":"https:\/\/etvnews.com\/","name":"Home","description":"Featured Story UPDATED:Highway 10 Accident Injures One October 11, 2012 Early Thursday afternoon, 30-year-old Sunee Young was headed northbound on Hwy 10 in a Volkswagen Jetta. When just before the Rocky Mountain Power office in Carbon County she bent down to look for something in her car and before she knew it, was headed off [\u2026]","url":"https:\/\/etvnews.com\/"},"nextItem":"https:\/\/etvnews.com\/frank-sacco\/#listItem"},{"@type":"ListItem","@id":"https:\/\/etvnews.com\/frank-sacco\/#listItem","position":"2","item":{"@type":"WebPage","@id":"https:\/\/etvnews.com\/frank-sacco\/","name":"Frank Sacco","description":"October 9, 1945 \u2013 August 7, 2021 To view the entire obituary, please click here.","url":"https:\/\/etvnews.com\/frank-sacco\/"},"previousItem":"https:\/\/etvnews.com\/#listItem"}]},{"@type":"Person","@id":"https:\/\/etvnews.com\/author\/skraync\/#author","url":"https:\/\/etvnews.com\/author\/skraync\/","name":"Scottie Draper","image":{"@type":"ImageObject","@id":"https:\/\/etvnews.com\/frank-sacco\/#authorImage","url":"https:\/\/secure.gravatar.com\/avatar\/9fe84e9b0c764d3e192395284ee3d95a?s=96&d=mm&r=g","width":"96","height":"96","caption":"Scottie Draper"},"sameAs":["https:\/\/www.facebook.com\/etvten"]},{"@type":"WebPage","@id":"https:\/\/etvnews.com\/frank-sacco\/#webpage","url":"https:\/\/etvnews.com\/frank-sacco\/","name":"Frank Sacco - ETV News","description":"October 9, 1945 \u2013 August 7, 2021 To view the entire obituary, please click here.","inLanguage":"en-US","isPartOf":{"@id":"https:\/\/etvnews.com\/#website"},"breadcrumb":{"@id":"https:\/\/etvnews.com\/frank-sacco\/#breadcrumblist"},"author":"https:\/\/etvnews.com\/frank-sacco\/#author","creator":"https:\/\/etvnews.com\/frank-sacco\/#author","image":{"@type":"ImageObject","@id":"https:\/\/etvnews.com\/#mainImage","url":"https:\/\/etvnews.com\/wp-content\/uploads\/2021\/08\/Frank-Sacco.jpeg","width":"400","height":"862"},"primaryImageOfPage":{"@id":"https:\/\/etvnews.com\/frank-sacco\/#mainImage"},"datePublished":"2021-08-09T17:40:01-07:00","dateModified":"2021-08-09T17:40:01-07:00"},{"@type":"BlogPosting","@id":"https:\/\/etvnews.com\/frank-sacco\/#blogposting","name":"Frank Sacco - ETV News","description":"October 9, 1945 \u2013 August 7, 2021 To view the entire obituary, please click here.","headline":"Frank Sacco","author":{"@id":"https:\/\/etvnews.com\/author\/skraync\/#author"},"publisher":{"@id":"https:\/\/etvnews.com\/#organization"},"datePublished":"2021-08-09T17:40:01-07:00","dateModified":"2021-08-09T17:40:01-07:00","articleSection":"Obituaries, 2021, carbon county, carbon county news, castle country news, castle dale, Clawson, Cleveland, East Carbon, Eastern Utah, elmo, emery county, emery county news, Emery Telcom, etv, ETV 10, ETV 10 News, etv news, ETV Newspaper, etv10, etv10news, etvnews, ferron, Frank Sacco, Free Newspaper, Green River, helper, Huntington, local news, Mitchell Funeral Home, News, newspaper, obituaries, obituary, orangeville, Price, Price City, Progress, rural news, Rural Utah, Southeast Utah, Sun Advocate, sunnyside, utah, utah news, Utah Newspaper, wellington","mainEntityOfPage":{"@id":"https:\/\/etvnews.com\/frank-sacco\/#webpage"},"isPartOf":{"@id":"https:\/\/etvnews.com\/frank-sacco\/#webpage"},"image":{"@type":"ImageObject","@id":"https:\/\/etvnews.com\/#articleImage","url":"https:\/\/etvnews.com\/wp-content\/uploads\/2021\/08\/Frank-Sacco.jpeg","width":"400","height":"862"}}]}
		</script>
		<!-- All in One SEO -->


<link rel='dns-prefetch' href='//www.google.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="ETV News &raquo; Feed" href="https://etvnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="ETV News &raquo; Comments Feed" href="https://etvnews.com/comments/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.15.1 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
    (window.gaDevIds=window.gaDevIds||[]).push("dZGIzZG");
	var mi_version         = '7.15.1';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-8101002-5';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-8101002-5', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/etvnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=026b79e0a0da26819c91fce8557b05fe"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- etvnews.com is managing ads with Advanced Ads 1.24.2 --><script>
						advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
						</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='newsplus-fontawesome-css'  href='https://etvnews.com/wp-content/plugins/newsplus-shortcodes/assets/css/font-awesome.min.css?ver=026b79e0a0da26819c91fce8557b05fe' type='text/css' media='all' />
<link rel='stylesheet' id='newsplus-shortcodes-css'  href='https://etvnews.com/wp-content/plugins/newsplus-shortcodes/assets/css/newsplus-shortcodes.css?ver=026b79e0a0da26819c91fce8557b05fe' type='text/css' media='all' />
<link rel='stylesheet' id='newsplus-owl-carousel-css'  href='https://etvnews.com/wp-content/plugins/newsplus-shortcodes/assets/css/owl.carousel.css' type='text/css' media='all' />
<link rel='stylesheet' id='newsplus-prettyphoto-css'  href='https://etvnews.com/wp-content/plugins/newsplus-shortcodes/assets/css/prettyPhoto.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://etvnews.com/wp-includes/css/dist/block-library/style.min.css?ver=026b79e0a0da26819c91fce8557b05fe' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://etvnews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='jltma-wpf-css'  href='https://etvnews.com/wp-content/plugins/prettyphoto/css/prettyPhoto.css?ver=026b79e0a0da26819c91fce8557b05fe' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css'  href='https://etvnews.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='monsterinsights-popular-posts-style-css'  href='https://etvnews.com/wp-content/plugins/google-analytics-for-wordpress/assets/css/frontend.min.css?ver=7.15.1' type='text/css' media='all' />
<link rel='stylesheet' id='evcal_google_fonts-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C300%7COpen+Sans%3A700%2C400%2C400i%7CRoboto%3A700%2C400&#038;ver=026b79e0a0da26819c91fce8557b05fe' type='text/css' media='screen' />
<link rel='stylesheet' id='evcal_cal_default-css'  href='//etvnews.com/wp-content/plugins/eventON/assets/css/eventon_styles.css?ver=2.7.3' type='text/css' media='all' />
<link rel='stylesheet' id='evo_font_icons-css'  href='//etvnews.com/wp-content/plugins/eventON/assets/fonts/font-awesome.css?ver=2.7.3' type='text/css' media='all' />
<style id='evo_dynamic_styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='eventon_em_styles-css'  href='//etvnews.com/wp-content/plugins/eventon-events-map/assets/evmap_style.css?ver=026b79e0a0da26819c91fce8557b05fe' type='text/css' media='all' />
<link rel='stylesheet' id='evo_fc_styles-css'  href='https://etvnews.com/wp-content/plugins/eventon-full-cal/assets/fc_styles.css?ver=026b79e0a0da26819c91fce8557b05fe' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='https://etvnews.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='newsplus-style-css'  href='https://etvnews.com/wp-content/themes/-new-newsplus/style.css?ver=026b79e0a0da26819c91fce8557b05fe' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='newsplus-ie-css'  href='https://etvnews.com/wp-content/themes/-new-newsplus/css/ie.css?ver=026b79e0a0da26819c91fce8557b05fe' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='newsplus-responsive-css'  href='https://etvnews.com/wp-content/themes/-new-newsplus/responsive.css?ver=026b79e0a0da26819c91fce8557b05fe' type='text/css' media='all' />
<link rel='stylesheet' id='newsplus-user-css'  href='https://etvnews.com/wp-content/themes/-new-newsplus/user.css?ver=026b79e0a0da26819c91fce8557b05fe' type='text/css' media='all' />
<link rel='stylesheet' id='__EPYT__style-css'  href='https://etvnews.com/wp-content/plugins/youtube-embed-plus-pro/styles/ytprefs.min.css?ver=13.4.1.2' type='text/css' media='all' />
<style id='__EPYT__style-inline-css' type='text/css'>

                .epyt-gallery-thumb {
                        width: 33.333%;
                }
                
                         @media (min-width:0px) and (max-width: 767px) {
                            .epyt-gallery-rowbreak {
                                display: none;
                            }
                            .epyt-gallery-allthumbs[class*="epyt-cols"] .epyt-gallery-thumb {
                                width: 100% !important;
                            }
                          }
</style>
<link rel='stylesheet' id='__disptype__-css'  href='https://etvnews.com/wp-content/plugins/youtube-embed-plus-pro/scripts/lity.min.css?ver=13.4.1.2' type='text/css' media='all' />
<link rel='stylesheet' id='awpcp-font-awesome-css'  href='https://use.fontawesome.com/releases/v5.2.0/css/all.css?ver=5.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='awpcp-frontend-style-css'  href='https://etvnews.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle.css?ver=4.1.4' type='text/css' media='all' />
<!--[if lte IE 6]>
<link rel='stylesheet' id='awpcp-frontend-style-ie-6-css'  href='https://etvnews.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-ie-6.css?ver=4.1.4' type='text/css' media='all' />
<![endif]-->
<!--[if lte IE 7]>
<link rel='stylesheet' id='awpcp-frontend-style-lte-ie-7-css'  href='https://etvnews.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-lte-ie-7.css?ver=4.1.4' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='kc-general-css'  href='https://etvnews.com/wp-content/plugins/kingcomposer/assets/frontend/css/kingcomposer.min.css?ver=2.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='kc-animate-css'  href='https://etvnews.com/wp-content/plugins/kingcomposer/assets/css/animate.css?ver=2.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='kc-icon-1-css'  href='https://etvnews.com/wp-content/plugins/kingcomposer/assets/css/icons.css?ver=2.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='jquery.lightbox.min.css-css'  href='https://etvnews.com/wp-content/plugins/wp-jquery-lightbox/styles/lightbox.min.css?ver=1.4.8.2' type='text/css' media='all' />
<script type='text/javascript' src='https://etvnews.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/etvnews.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://etvnews.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.15.1' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='https://etvnews.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1' id='addtoany-js'></script>
<script type='text/javascript' src='https://etvnews.com/wp-content/plugins/youtube-embed-plus-pro/scripts/lity.min.js?ver=13.4.1.2' id='__dispload__-js'></script>
<script type='text/javascript' id='__ytprefs__-js-extra'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"https:\/\/etvnews.com\/wp-admin\/admin-ajax.php","security":"cc285b9a02","gallery_scrolloffset":"20","eppathtoscripts":"https:\/\/etvnews.com\/wp-content\/plugins\/youtube-embed-plus-pro\/scripts\/","eppath":"https:\/\/etvnews.com\/wp-content\/plugins\/youtube-embed-plus-pro\/","epresponsiveselector":"[\"iframe.__youtube_prefs__\",\"iframe[src*='youtube.com']\",\"iframe[src*='youtube-nocookie.com']\",\"iframe[data-ep-src*='youtube.com']\",\"iframe[data-ep-src*='youtube-nocookie.com']\",\"iframe[data-ep-gallerysrc*='youtube.com']\"]","epdovol":"1","version":"13.4.1.2","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","ytapi_load":"light","pause_others":"","stopMobileBuffer":"1","vi_active":"","vi_js_posttypes":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://etvnews.com/wp-content/plugins/youtube-embed-plus-pro/scripts/ytprefs.min.js?ver=13.4.1.2' id='__ytprefs__-js'></script>
<link rel="https://api.w.org/" href="https://etvnews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://etvnews.com/wp-json/wp/v2/posts/470469" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://etvnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://etvnews.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Don Oveson' href='https://etvnews.com/don-oveson/' />
<link rel='next' title='Bill Hatfield' href='https://etvnews.com/bill-hatfield/' />

<link rel='shortlink' href='https://etvnews.com/?p=470469' />
<link rel="alternate" type="application/json+oembed" href="https://etvnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fetvnews.com%2Ffrank-sacco%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://etvnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fetvnews.com%2Ffrank-sacco%2F&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<meta name="generator" content="Custom Login v3.2.11" />
<script type="text/javascript">var kc_script_data={ajax_url:"https://etvnews.com/wp-admin/admin-ajax.php"}</script><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//etvnews.com/?wordfence_lh=1&hid=37082031D5B7FA4C14794BAC59141596');
</script><style type="text/css" media="screen"></style>		<style type="text/css">
			.primary-nav {
				background-color:;
			}
			ul.nav-menu > li > a {
				text-shadow: none;
				color:;
			}
			.primary-nav li:hover > a {
				color:;
				border-bottom-color: ;
			}
			ul.nav-menu > li.current-menu-item > a,
			ul.nav-menu > li.current-menu-ancestor > a,
			ul.nav-menu > li.current_page_item > a,
			ul.nav-menu > li.current_page_ancestor > a {
				border-bottom-color: #990000;
				color:  ;
			}
			.primary-nav li ul {
				background-color:;
			}
			.primary-nav li ul li a {
				color:;
			}
			.primary-nav li ul li:hover > a {
				color:;
				background-color:;
			}
			.sb-title {
				color:;
			}
			#secondary {
				color:;
				background-color:;
			}
			#secondary .sep {
				color:;
			}
			#secondary .widget a,
			#secondary .widget ul a {
				color:;
			}
			#secondary .widget a:hover,
			#secondary .widget ul a:hover {
				color:;
			}
			.sc-title {
				color:;
			}
			#secondary .widget ul li,
			#secondary .post-list > li:after {
				border-bottom-color: ;
			}
		
			#secondary .widget ul ul {
				border-top-color: ;
			}
			#footer {
				color:;
				background-color:;
			}
			body.is-stretched.custom-background {
				background-color:;
			}
			#footer a {
				color:;
			}
			#footer a:hover {
				color:;
			}
		</style>
				<style id="newsplus-custom-css" type="text/css">
		.sp-label-archive { color:;background:;}.sp-post .entry-content, .sp-post .card-content, .sp-post.entry-classic{background:;}.main-row,.two-sidebars .primary-row { margin: 0 -15px; }#primary, #container, #sidebar, .two-sidebars #content, .two-sidebars #sidebar-b, .entry-header.full-header, .ad-area-above-content { padding: 0 15px; }		body {
			font-size: 14px;
		}
				#page {
			max-width: 1240px;
		}
		.wrap,
		.primary-nav,
		.is-boxed .top-nav,
		.is-boxed .header-slim.site-header {
			max-width: 1192px;
		}
		@media only screen and (max-width: 1288px) {
			.wrap,
			.primary-nav,
			.is-boxed .top-nav,
			.is-boxed .header-slim.site-header,
			.is-stretched .top-nav .wrap {
				max-width: calc(100% - 48px);
			}
			.is-boxed .sticky-nav,
			.is-boxed .header-slim.sticky-nav,
			.is-boxed #responsive-menu.sticky-nav {
				max-width: calc(97.5% - 48px);
			}
		}
				</style>
		<!--[if lt IE 9]>
	<script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script>
	<![endif]-->


<!-- EventON Version -->
<meta name="generator" content="EventON 2.7.3" />

<link rel="canonical" href="https://etvnews.com/frank-sacco/" />
<link rel="icon" href="https://etvnews.com/wp-content/uploads/2020/10/favicon-1-80x80.png" sizes="32x32" />
<link rel="icon" href="https://etvnews.com/wp-content/uploads/2020/10/favicon-1-200x200.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://etvnews.com/wp-content/uploads/2020/10/favicon-1-200x200.png" />
<meta name="msapplication-TileImage" content="https://etvnews.com/wp-content/uploads/2020/10/favicon-1-300x300.png" />
</head>

<body class="post-template-default single single-post postid-470469 single-format-standard kc-css-system is-boxed split-70-30 layout-ca scheme-customizer aa-prefix-etvne-">
	    <div id="page" class="hfeed site clear">
            <div id="utility-top" class="top-nav">
            <div class="wrap clear">
                                <nav id="optional-nav" class="secondary-nav">
                    <ul id="menu-header-menu" class="sec-menu clear"><li id="menu-item-6641" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6641"><a href="https://www.emerytelcom.com">Emery Telcom</a></li>
<li id="menu-item-6644" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6644"><a href="https://etvnews.com/contact-us/">Contact Us</a></li>
<li id="menu-item-6690" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6690"><a href="https://etvnews.com/etv-classifieds/">ETV Classifieds</a></li>
<li id="menu-item-214335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-214335"><a href="https://etvnews.com/etv-10/">ETV 10</a></li>
<li id="menu-item-437809" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-437809"><a href="https://etvnews.com/policies/">Policies</a></li>
</ul>                </nav><!-- #optional-nav -->
                                <div id="search-bar" role="complementary">
                    <form role="search" method="get" class="search-form" action="https://etvnews.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>                </div><!-- #search-bar -->
                            </div><!-- .top-nav .wrap -->
        </div><!-- .top-nav-->
		            <header id="header" class="site-header">
                <div class="wrap full-width clear">    
                    <div class="brand column one-fourth">
        <h4 class="site-title"><a href="https://etvnews.com/" title="ETV News" rel="home"><img src="https://www2.etvnews.com/wp-content/uploads/2015/08/ETV-news-logo@2x.png" alt="ETV News" /></a></h4>    </div><!-- .column one-third -->
        <div class="column header-widget-area right last">
        <aside id="custom_html-6" class="widget_text hwa-wrap widget_custom_html"><div class="textwidget custom-html-widget"><div class="etvne-header-placement" id="etvne-1243998757"><a href="https://autofarmgroup.com/"><img loading="lazy" src="https://etvnews.com/wp-content/uploads/2021/05/AutoFarm-Banner-Carfax-scaled.jpg" alt=""  width="826" height="111"   /></a></div>

<!-- [dfads params='groups=1745&limit=1&orderby=random'] --></div></aside>        </div><!-- .header-widget-area -->
	                </div><!-- #header .wrap -->
            </header><!-- #header -->
        					<div id="responsive-menu" class="resp-main">
                        <div class="wrap">
							                         
                            <h3 class="menu-button"><span class="screen-reader-text">Menu</span>Menu<span class="toggle-icon"><span class="bar-1"></span><span class="bar-2"></span><span class="bar-3"></span></span></h3>
                        </div><!-- /.wrap -->
						<nav class="menu-drop"></nav><!-- /.menu-drop -->                        
					</div><!-- /#responsive-menu -->
				            <nav id="main-nav" class="primary-nav">
                <div class="wrap clearfix">
                    <ul id="menu-main-menu" class="nav-menu clear"><li id="menu-item-6484" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-6484"><a href="https://etvnews.com/">Home</a></li>
<li id="menu-item-20579" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-20579"><a href="https://etvnews.com/category/local-news/">Local News</a>
<ul class="sub-menu">
	<li id="menu-item-333847" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333847"><a href="https://etvnews.com/category/announcements/">Announcements</a></li>
	<li id="menu-item-283723" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-283723"><a href="https://etvnews.com/community-events/">Community Events</a></li>
	<li id="menu-item-395760" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-395760"><a href="https://etvnews.com/events-calendar/">Events Calendar</a></li>
	<li id="menu-item-437640" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-437640"><a href="https://etvnews.com/category/business-spotlight/">Business Spotlight</a></li>
</ul>
</li>
<li id="menu-item-20524" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-20524"><a href="https://etvnews.com/category/local-sports/">Local Sports</a>
<ul class="sub-menu">
	<li id="menu-item-20594" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20594"><a href="https://etvnews.com/category/local-sports/baseball/">Baseball</a></li>
	<li id="menu-item-20595" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20595"><a href="https://etvnews.com/category/local-sports/basketball/">Basketball</a></li>
	<li id="menu-item-181382" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181382"><a href="https://etvnews.com/category/local-sports/cross-country/">Cross Country</a></li>
	<li id="menu-item-20596" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20596"><a href="https://etvnews.com/category/local-sports/football/">Football</a></li>
	<li id="menu-item-181385" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181385"><a href="https://etvnews.com/category/local-sports/golf-local-sports/">Golf</a></li>
	<li id="menu-item-181386" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181386"><a href="https://etvnews.com/category/local-sports/mma-local-sports/">MMA</a></li>
	<li id="menu-item-181387" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181387"><a href="https://etvnews.com/category/local-sports/motocross-local-sports/">Motocross</a></li>
	<li id="menu-item-181388" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181388"><a href="https://etvnews.com/category/local-sports/outdoors-local-sports/">Outdoors</a></li>
	<li id="menu-item-181389" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181389"><a href="https://etvnews.com/category/local-sports/rodeo/">Rodeo</a></li>
	<li id="menu-item-20597" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20597"><a href="https://etvnews.com/category/local-sports/soccer/">Soccer</a></li>
	<li id="menu-item-20598" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20598"><a href="https://etvnews.com/category/local-sports/softball-139/">Softball</a></li>
	<li id="menu-item-20609" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20609"><a href="https://etvnews.com/category/local-sports/swimming-local-sports/">Swimming</a></li>
	<li id="menu-item-181391" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181391"><a href="https://etvnews.com/category/local-sports/tennis-local-sports/">Tennis</a></li>
	<li id="menu-item-20599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20599"><a href="https://etvnews.com/category/local-sports/track-field/">Track &#038; Field</a></li>
	<li id="menu-item-181392" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-181392"><a href="https://etvnews.com/category/local-sports/volleyball-local-sports/">Volleyball</a></li>
	<li id="menu-item-20600" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-20600"><a href="https://etvnews.com/category/local-sports/wrestling/">Wrestling</a></li>
</ul>
</li>
<li id="menu-item-423697" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-423697"><a href="https://etvnews.com/livesports/">Live Sports</a></li>
<li id="menu-item-61123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-61123"><a href="https://etvnews.com/category/youth-education/">Youth &amp; Education</a></li>
<li id="menu-item-254474" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-254474"><a href="https://etvnews.com/category/notices/">Notices</a>
<ul class="sub-menu">
	<li id="menu-item-282659" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-282659"><a href="https://etvnews.com/category/notices/">Recent Notices</a></li>
	<li id="menu-item-282658" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-282658"><a href="https://etvnews.com/submit-notices-to-etv-10/">Submit A Notice</a></li>
</ul>
</li>
<li id="menu-item-204346" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-204346"><a href="https://etvnews.com/category/opinion/">Opinion</a></li>
<li id="menu-item-20725" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-20725"><a href="https://etvnews.com/weather-cameras/">Weather Cameras</a>
<ul class="sub-menu">
	<li id="menu-item-20925" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20925"><a href="https://etvnews.com/weather-cameras/emery-weather-camera/">Emery Weather Camera</a></li>
	<li id="menu-item-20918" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20918"><a href="https://etvnews.com/weather-cameras/cedar-mountain-weather-camera/">Cedar Mountain Weather Camera</a></li>
	<li id="menu-item-20919" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20919"><a href="https://etvnews.com/weather-cameras/east-carbon-weather-camera/">East Carbon Weather Camera</a></li>
	<li id="menu-item-20920" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20920"><a href="https://etvnews.com/weather-cameras/huntington-weather-camera/">Huntington Weather Camera</a></li>
	<li id="menu-item-20922" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20922"><a href="https://etvnews.com/weather-cameras/ferron-weather-camera-1/">Ferron Weather Camera 1</a></li>
	<li id="menu-item-20921" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20921"><a href="https://etvnews.com/weather-cameras/ferron-weather-camera-2/">Ferron Weather Camera 2</a></li>
	<li id="menu-item-20924" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20924"><a href="https://etvnews.com/weather-cameras/horn-mountain-weather-camera-1/">Horn Mountain Weather Camera 1</a></li>
	<li id="menu-item-20923" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20923"><a href="https://etvnews.com/weather-cameras/horn-mountain-weather-camera-2/">Horn Mountain Weather Camera 2</a></li>
	<li id="menu-item-20926" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20926"><a href="https://etvnews.com/weather-cameras/green-river-weather-camera/">Green River Weather Camera</a></li>
	<li id="menu-item-20927" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-20927"><a href="https://etvnews.com/weather-cameras/moab-weather-camera/">Moab Weather Camera</a></li>
	<li id="menu-item-338084" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-338084"><a href="https://etvnews.com/weather-cameras/teasdale-weather-camera/">Teasdale Weather Camera</a></li>
</ul>
</li>
<li id="menu-item-336462" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-336462"><a href="https://etvnews.com/obituaries/">Obituaries</a>
<ul class="sub-menu">
	<li id="menu-item-336464" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-336464"><a href="https://etvnews.com/obituaries/">Obituaries</a></li>
	<li id="menu-item-336463" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-336463"><a href="https://etvnews.com/submit-an-obituary/">Submit An Obituary</a></li>
</ul>
</li>
<li id="menu-item-6689" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6689"><a href="https://etvnews.com/etv-classifieds/">Classifieds</a></li>
</ul>     
                    
                </div><!-- .primary-nav .wrap -->
            </nav><!-- #main-nav -->
		
		        <div id="main">
            <div class="wrap clearfix">
            	<div class="main-row clearfix">    <div class="ad-area-above-content">
                <div class="marketing-area">
            <div class="etvne-manual-placement" id="etvne-443174194"><a href="https://autofarmgroup.com/"><img src="https://etvnews.com/wp-content/uploads/2021/05/AutoFarm-Banner-Carfax-scaled.jpg" alt=""  width="826" height="111"   /></a></div>            </div>
            </div><!-- /.ad-area-above-content -->
<div id="primary" class="site-content">
	<div class="primary-row">
        <div id="content" role="main">
			<ol class="breadcrumbs"><li><a href="https://etvnews.com"><span>Home</span></a></li><li><a href="https://etvnews.com/category/obituaries/"><span>Obituaries</span></a></li><li><span><span>Frank Sacco</span></span></li></ol>
                    <article  id="post-470469" class="newsplus main-article post-470469 post type-post status-publish format-standard has-post-thumbnail hentry category-obituaries tag-15526 tag-carbon-county tag-carbon-county-news tag-castle-country-news tag-castle-dale tag-clawson tag-cleveland tag-east-carbon tag-eastern-utah tag-elmo tag-emery-county tag-emery-county-news tag-emerytelcom tag-etv tag-etv-10 tag-etv-10-news tag-etv-news tag-etv-newspaper tag-etv10 tag-etv10news tag-etvnews tag-ferron tag-frank-sacco tag-free-newspaper tag-green-river tag-helper tag-huntington tag-localnews-k223 tag-mitchell-funeral-home tag-news tag-newspaper tag-obituaries-1 tag-obituary tag-orangeville tag-price tag-price-city tag-progress tag-rural-news tag-rural-utah tag-southeast-utah tag-sun-advocate tag-sunnyside tag-utah tag-utah-news-1 tag-utah-newspaper tag-wellington">
                                                <header class="entry-header single-meta">
                                <aside class="meta-row cat-row"><div class="meta-col"><ul class="post-categories"><li><a href="https://etvnews.com/category/obituaries/">Obituaries</a></li></ul></div></aside><h1 class="entry-title">Frank Sacco</h1><aside class="meta-row row-3"><div class="meta-col"><ul class="entry-meta"><li class="post-time"><span class="published-label">Published: </span><span class="posted-on"><time class="entry-date" datetime="2021-08-09T10:40:01-07:00">August 9, 2021<span class="sep time-sep"></span><span class="publish-time">10:40 am</span></time></span></li><li class="post-author"><span class="screen-reader-text">Author </span><a href="https://etvnews.com/author/">Scottie Draper</a></li></ul></div></aside><div class="single-post-thumb"><img src="https://etvnews.com/wp-content/uploads/2021/08/Frank-Sacco.jpeg" class="attachment-post-thumbnail wp-post-image" alt="Frank-Sacco.jpeg"></div>                            </header>
                        
                        <div class="entry-content articlebody">
                            <div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://etvnews.com/frank-sacco/" data-a2a-title="Frank Sacco"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fetvnews.com%2Ffrank-sacco%2F&amp;linkname=Frank%20Sacco" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fetvnews.com%2Ffrank-sacco%2F&amp;linkname=Frank%20Sacco" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_pinterest" href="https://www.addtoany.com/add_to/pinterest?linkurl=https%3A%2F%2Fetvnews.com%2Ffrank-sacco%2F&amp;linkname=Frank%20Sacco" title="Pinterest" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fetvnews.com%2Ffrank-sacco%2F&amp;linkname=Frank%20Sacco" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_print" href="https://www.addtoany.com/add_to/print?linkurl=https%3A%2F%2Fetvnews.com%2Ffrank-sacco%2F&amp;linkname=Frank%20Sacco" title="Print" rel="nofollow noopener" target="_blank"></a></div></div><p>October 9, 1945 &#8211; August 7, 2021</p>
<p>To view the entire obituary, <a href="https://www.mitchellfuneralhome.net/obituary/frank-sacco">please click here. </a></p>
                        </div><!-- .entry-content -->

                        <footer class="entry-footer">
                                                    </footer><!-- .entry-footer -->
                    </article><!-- #post-470469 -->

                    
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://etvnews.com/don-oveson/" rel="prev"><span class="meta-nav" aria-hidden="true">Previous</span> <span class="screen-reader-text">Previous post:</span> <span class="post-title">Don Oveson</span></a></div><div class="nav-next"><a href="https://etvnews.com/bill-hatfield/" rel="next"><span class="meta-nav" aria-hidden="true">Next</span> <span class="screen-reader-text">Next post:</span> <span class="post-title">Bill Hatfield</span></a></div></div>
	</nav>                            <div class="marketing-area">
                                <div><div class="dfad dfad_pos_1 dfad_first" id="_ad_265086"><a href="https://emerytelcom.com" target="_blank" rel="noopener noreferrer"><img src="https://etvnews.com/wp-content/uploads/2018/06/ETV-Banner-Ad_January2021B.jpg" alt="" width="826" height="111" class="alignnone size-full wp-image-427537" /></a></div></div>                            </div>
                                    </div><!-- #content -->
            </div><!-- .primary-row -->
</div><!-- #primary -->
<div id="sidebar" class="widget-area" role="complementary">
<aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><button class="red-button" style="width: 100%">
	<a href="/livesports" style="color: white; font-size: large;">
	CLICK HERE FOR LIVE SPORTS!
		</a>
</button></div></aside><aside id="custom_html-14" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div><div class="dfad dfad_pos_1 dfad_first" id="_ad_370353"><a href="https://gagonfamilymedicine.com/" target="_blank" rel="noopener noreferrer">
<img src="https://etvnews.com/wp-content/uploads/2019/12/Unknown-2.png" alt="" width="344" height="501" class="alignnone size-full wp-image-440083" /></a></div></div></div></aside><aside id="awpcp-latest-ads-4" class="widget widget_awpcp-latest-ads"><h3 class="sb-title">Latest Classifieds</h3><ul class="awpcp-listings-widget-items-list"><li class="awpcp-listings-widget-item awpcp-listings-widget-item-with-left-thumbnail-in-desktop awpcp-listings-widget-item-with-thumbnail-above-in-mobile  awpcp-listings-widget-item-without-thumbnail"><div class="awpcplatestbox awpcp-clearfix"><div class="awpcp-listings-widget-item--title-and-content"><div class="awpcp-listing-title"><a href="https://etvnews.com/etv-classifieds/show-ad/448288/help-wanted-emery-carbon-animal-health/help-wanted/">HELP WANTED - Emery &amp; Carbon Animal Health</a></div> <div class="awpcp-listings-widget-item-excerpt">Emery &amp; Carbon Animal Health wants to invest in you. Yes, you! We&#039;re looking for people who are problem-solvers, team&hellip;</div></div><p class="awpcp-widget-read-more-container"><a class="awpcp-widget-read-more" href="https://etvnews.com/etv-classifieds/show-ad/448288/help-wanted-emery-carbon-animal-health/help-wanted/">[Read more]</a></p></div></li>
<li class="awpcp-listings-widget-item awpcp-listings-widget-item-with-left-thumbnail-in-desktop awpcp-listings-widget-item-with-thumbnail-above-in-mobile  awpcp-listings-widget-item-without-thumbnail"><div class="awpcplatestbox awpcp-clearfix"><div class="awpcp-listings-widget-item--title-and-content"><div class="awpcp-listing-title"><a href="https://etvnews.com/etv-classifieds/show-ad/456799/home-improvement/seeking-employment/">Home Improvement</a></div> <div class="awpcp-listings-widget-item-excerpt">J&amp;J Residential Restoration &amp; Repair Consulting. Free project analysis. Call us. Ph: 435 609-6877.</div></div><p class="awpcp-widget-read-more-container"><a class="awpcp-widget-read-more" href="https://etvnews.com/etv-classifieds/show-ad/456799/home-improvement/seeking-employment/">[Read more]</a></p></div></li>
<li class="awpcp-listings-widget-item awpcp-listings-widget-item-with-left-thumbnail-in-desktop awpcp-listings-widget-item-with-thumbnail-above-in-mobile  awpcp-listings-widget-item-without-thumbnail"><div class="awpcplatestbox awpcp-clearfix"><div class="awpcp-listings-widget-item--title-and-content"><div class="awpcp-listing-title"><a href="https://etvnews.com/etv-classifieds/show-ad/469652/now-hiring-cfm-heating-air-conditioning/help-wanted/">NOW HIRING - CFM Heating & Air Conditioning</a></div> <div class="awpcp-listings-widget-item-excerpt">CFM Heating &amp; Air Conditioning is looking for Commercial HVAC Apprentices and Journeymen (multiple positions available). We have a project&hellip;</div></div><p class="awpcp-widget-read-more-container"><a class="awpcp-widget-read-more" href="https://etvnews.com/etv-classifieds/show-ad/469652/now-hiring-cfm-heating-air-conditioning/help-wanted/">[Read more]</a></p></div></li></ul></aside><aside id="custom_html-19" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- <div style="text-align: center; border: 1px solid #0C7CBA; border-radius: 5px; padding: 5px;">
	<a href="/carbon-nation">Read the Latest Edition of
	<img src="https://etvnews.com/wp-content/uploads/2021/02/CarbonNation@2x.png" alt="Carbon Nation" />
		</a>
</div> --></div></aside><aside id="custom_html-4" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div><div class="dfad dfad_pos_1 dfad_first" id="_ad_370353"><a href="https://gagonfamilymedicine.com/" target="_blank" rel="noopener noreferrer">
<img src="https://etvnews.com/wp-content/uploads/2019/12/Unknown-2.png" alt="" width="344" height="501" class="alignnone size-full wp-image-440083" /></a></div></div></div></aside><aside id="newsplus-recent-posts-4" class="widget newsplus_recent_posts"><h3 class="sb-title">Recent Notices</h3><div class="list-small-wrap clearfix fs-16 kc-elm">	<article class="newsplus entry-list list-small split-33-67 no-image post-468305 post type-post status-publish format-standard hentry category-notices">
		<div class="entry-content"><h2 class="entry-title"><a href="https://etvnews.com/notice-of-public-hearing-60/" title="NOTICE OF PUBLIC HEARING">NOTICE OF PUBLIC HEARING</a></h2><aside class="meta-row row-3"><div class="meta-col"><ul class="entry-meta"><li class="post-time"><span class="published-label">Published: </span><span class="posted-on"><time class="entry-date" datetime="2021-08-04T01:40:32-07:00">August 4, 2021<span class="sep time-sep"></span><span class="publish-time">1:40 am</span></time></span><span class="sep updated-sep"></span><span class="updated-on"><meta itemprop="dateModified" content="2021-07-29T14:09:44-07:00">Updated: July 29, 2021<span class="sep time-sep"></span><span class="updated-time">2:09 pm</a></span></li><li class="post-author"><span class="screen-reader-text">Author </span><a href="https://etvnews.com/author/skraync/">Scottie Draper</a></li></ul></div></aside>		</div><!-- /.entry-content -->
	</article><!-- #post-468305 -->
		<article class="newsplus entry-list list-small split-33-67 no-image post-468302 post type-post status-publish format-standard hentry category-notices">
		<div class="entry-content"><h2 class="entry-title"><a href="https://etvnews.com/announcement-of-appointment-and-notice-to-creditors-15/" title="ANNOUNCEMENT OF APPOINTMENT AND NOTICE TO CREDITORS">ANNOUNCEMENT OF APPOINTMENT AND NOTICE TO CREDITORS</a></h2><aside class="meta-row row-3"><div class="meta-col"><ul class="entry-meta"><li class="post-time"><span class="published-label">Published: </span><span class="posted-on"><time class="entry-date" datetime="2021-08-04T01:30:58-07:00">August 4, 2021<span class="sep time-sep"></span><span class="publish-time">1:30 am</span></time></span><span class="sep updated-sep"></span><span class="updated-on"><meta itemprop="dateModified" content="2021-07-29T11:23:22-07:00">Updated: July 29, 2021<span class="sep time-sep"></span><span class="updated-time">11:23 am</a></span></li><li class="post-author"><span class="screen-reader-text">Author </span><a href="https://etvnews.com/author/skraync/">Scottie Draper</a></li></ul></div></aside>		</div><!-- /.entry-content -->
	</article><!-- #post-468302 -->
		<article class="newsplus entry-list list-small split-33-67 no-image post-468234 post type-post status-publish format-standard hentry category-notices">
		<div class="entry-content"><h2 class="entry-title"><a href="https://etvnews.com/public-notice-of-cancellation-of-meeting-price-municipal-corporation-planning-zoning-commission-13/" title="PUBLIC NOTICE OF CANCELLATION OF MEETING &#8211; PRICE MUNICIPAL CORPORATION &#8211; PLANNING &#038; ZONING COMMISSION">PUBLIC NOTICE OF CANCELLATION OF MEETING &#8211; PRICE MUNICIPAL CORPORATION &#8211; PLANNING &#038; ZONING COMMISSION</a></h2><aside class="meta-row row-3"><div class="meta-col"><ul class="entry-meta"><li class="post-time"><span class="published-label">Published: </span><span class="posted-on"><time class="entry-date" datetime="2021-08-04T01:20:48-07:00">August 4, 2021<span class="sep time-sep"></span><span class="publish-time">1:20 am</span></time></span><span class="sep updated-sep"></span><span class="updated-on"><meta itemprop="dateModified" content="2021-07-28T11:22:31-07:00">Updated: July 28, 2021<span class="sep time-sep"></span><span class="updated-time">11:22 am</a></span></li><li class="post-author"><span class="screen-reader-text">Author </span><a href="https://etvnews.com/author/skraync/">Scottie Draper</a></li></ul></div></aside>		</div><!-- /.entry-content -->
	</article><!-- #post-468234 -->
	</div><!-- /.list-big-wrap --></aside><aside class="widget etvne-widget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block;" data-ad-client="ca-pub-3987983992836491" 
data-ad-slot="" 
data-ad-format="auto" data-full-width-responsive="true"></ins>
<script> 
(adsbygoogle = window.adsbygoogle || []).push({}); 
</script>
</aside></div><!-- #sidebar -->            </div><!-- .row -->
        </div><!-- #main .wrap -->
    </div><!-- #main -->
            <div id="secondary" class="columns-2" role="complementary">
            <div class="wrap clearfix">
                <div class="row">
                <aside id="text-22" class="widget widget_text"><h3 class="sc-title">ETV News</h3>			<div class="textwidget"><p style="margin-top: -10px;">625 East 100 North<br>Price, UT 84501<br>(435) 636-3941<br><a href="mailto:etv@emerytelcom.com" style="text-decoration: underline">etv@emerytelcom.com</a></p></div>
		</aside><aside id="newsplus-social-2" class="widget newsplus_social"><h3 class="sc-title">Connect with ETV News</h3><ul class="ss-social"><li><a href="https://twitter.com/etv10news" title="Twitter" class="ss-twitter"><i class="fa fa-twitter"></i><span class="sr-only">twitter</span></a></li><li><a href="https://www.facebook.com/Etv-Ten-526054250827711/?fref=ts" title="Facebook" class="ss-facebook"><i class="fa fa-facebook"></i><span class="sr-only">facebook</span></a></li><li><a href="https://www.instagram.com/etv.news/" title="Instagram" class="ss-instagram"><i class="fa fa-instagram"></i><span class="sr-only">instagram</span></a></li><li><a href="https://www.youtube.com/channel/UCgi2RM-oPJpGk_c5kVCqo9A" title="Youtube" class="ss-youtube"><i class="fa fa-youtube"></i><span class="sr-only">youtube</span></a></li><li><a href="mailto:etv@emerytelcom.com" title="Email" class="ss-envelope"><i class="fa fa-envelope"></i><span class="sr-only">email</span></a></li></ul></aside>                </div><!-- /.row -->
            </div><!-- #secondary .wrap -->
        </div><!-- #secondary -->
        <footer id="footer">
        <div class="wrap clear">
            <div class="notes-left">© <script>new Date().getFullYear()>document.write(+new Date().getFullYear());</script>, Emery Telcom. All rights reserved.</div><!-- .notes-left -->
            <div class="notes-right"><a href="https://etvnews.com/policies/">ETV News Policies</a></div><!-- .notes-right -->
        </div><!-- #footer wrap -->
    </footer><!-- #footer -->
    
    <div class="fixed-widget-bar fixed-left">
            </div><!-- /.fixed-left -->
    
    <div class="fixed-widget-bar fixed-right">
            </div><!-- /.fixed-right -->

</div> <!-- #page -->

<div class="scroll-to-top"><a href="#" title="Scroll to top"><span class="sr-only">scroll to top</span></a></div><!-- .scroll-to-top -->
		<script type="text/javascript" alt='evo_map_styles'>
		/*<![CDATA[*/
		var gmapstyles = 'default';
		/* ]]> */
		</script>		
		
			<script type="text/javascript" charset="utf-8">
			    jQuery(document).ready(function() {
				    jQuery("a[rel^='prettyPhoto']").prettyPhoto({
					    deeplinking: false,
				    });
			    });
			</script>

		<div class='evo_lightboxes' style='display:block'>					<div class='evo_lightbox eventcard eventon_events_list' id='' >
						<div class="evo_content_in">													
							<div class="evo_content_inin">
								<div class="evo_lightbox_content">
									<a class='evolbclose '>X</a>
									<div class='evo_lightbox_body eventon_list_event evo_pop_body evcal_eventcard'> </div>
								</div>
							</div>							
						</div>
					</div>
										<div class='evo_lightbox evoau_lightbox ' id='evoau_lightbox' >
						<div class="evo_content_in">													
							<div class="evo_content_inin">
								<div class="evo_lightbox_content">
									<a class='evolbclose evoau_lightbox'>X</a>
									<div class='evo_lightbox_body '> </div>
								</div>
							</div>							
						</div>
					</div>
					</div><script type='text/javascript' src='https://etvnews.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://etvnews.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script>
<script type='text/javascript' src='https://etvnews.com/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b' id='jquery-masonry-js'></script>
<script type='text/javascript' src='https://etvnews.com/wp-content/plugins/newsplus-shortcodes/assets/js/custom.js?ver=026b79e0a0da26819c91fce8557b05fe' id='newsplus-custom-js-js'></script>
<script type='text/javascript' src='https://etvnews.com/wp-content/plugins/newsplus-shortcodes/assets/js/jquery.easing.min.js?ver=026b79e0a0da26819c91fce8557b05fe' id='jq-easing-js'></script>
<script type='text/javascript' src='https://etvnews.com/wp-content/plugins/newsplus-shortcodes/assets/js/owl.carousel.min.js?ver=026b79e0a0da26819c91fce8557b05fe' id='newsplus-jq-owl-carousel-js'></script>
<script type='text/javascript' src='https://etvnews.com/wp-content/plugins/newsplus-shortcodes/assets/js/jquery.prettyPhoto.js?ver=026b79e0a0da26819c91fce8557b05fe' id='newsplus-prettyphoto-js-js'></script>
<script type='text/javascript' src='https://etvnews.com/wp-content/plugins/newsplus-shortcodes/assets/js/jquery.marquee.min.js?ver=026b79e0a0da26819c91fce8557b05fe' id='jq-marquee-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/etvnews.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://etvnews.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.3.2' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://etvnews.com/wp-content/plugins/prettyphoto/js/jquery.prettyPhoto.js?ver=1.2.3' id='jltma-wpf-js'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js?render=6LcNt4YUAAAAAE_Gi9Jr79JC-I7gH_tTOwORulkk&#038;ver=3.0' id='google-recaptcha-js'></script>
<script type='text/javascript' id='wpcf7-recaptcha-js-extra'>
/* <![CDATA[ */
var wpcf7_recaptcha = {"sitekey":"6LcNt4YUAAAAAE_Gi9Jr79JC-I7gH_tTOwORulkk","actions":{"homepage":"homepage","contactform":"contactform"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://etvnews.com/wp-content/plugins/contact-form-7/modules/recaptcha/script.js?ver=5.3.2' id='wpcf7-recaptcha-js'></script>
<script type='text/javascript' src='//etvnews.com/wp-content/plugins/eventON/assets/js/eventon_functions.js?ver=2.7.3' id='evcal_functions-js'></script>
<script type='text/javascript' src='https://etvnews.com/wp-content/plugins/eventON/assets/js/handlebars.js?ver=2.7.3' id='evo_handlebars-js'></script>
<script type='text/javascript' src='//etvnews.com/wp-content/plugins/eventON/assets/js/jquery.mobile.min.js?ver=2.7.3' id='evo_mobile-js'></script>
<script type='text/javascript' src='//etvnews.com/wp-content/plugins/eventON/assets/js/jquery.mousewheel.min.js?ver=2.7.3' id='evo_mouse-js'></script>
<script type='text/javascript' id='evcal_ajax_handle-js-extra'>
/* <![CDATA[ */
var the_ajax_script = {"ajaxurl":"https:\/\/etvnews.com\/wp-admin\/admin-ajax.php","postnonce":"3d56b1b79e"};
/* ]]> */
</script>
<script type='text/javascript' src='//etvnews.com/wp-content/plugins/eventON/assets/js/eventon_script.js?ver=2.7.3' id='evcal_ajax_handle-js'></script>
<script type='text/javascript' id='custom-js-extra'>
/* <![CDATA[ */
var ss_custom = {"top_bar_sticky":"","main_bar_sticky":"true","expand_menu_text":"Expand or collapse submenu","header_style":"default","mobile_sticky":"","collapse_lists":"","enable_responsive_menu":"true"};
/* ]]> */
</script>
<script type='text/javascript' src='https://etvnews.com/wp-content/themes/-new-newsplus/js/custom.js?ver=026b79e0a0da26819c91fce8557b05fe' id='custom-js'></script>
<script type='text/javascript' src='https://etvnews.com/wp-content/plugins/youtube-embed-plus-pro/scripts/fitvids.min.js?ver=13.4.1.2' id='__ytprefsfitvids__-js'></script>
<script type='text/javascript' src='https://etvnews.com/wp-content/plugins/kingcomposer/assets/frontend/js/kingcomposer.min.js?ver=2.9.6' id='kc-front-scripts-js'></script>
<script type='text/javascript' src='https://etvnews.com/wp-content/plugins/wp-jquery-lightbox/jquery.touchwipe.min.js?ver=1.4.8.2' id='wp-jquery-lightbox-swipe-js'></script>
<script type='text/javascript' id='wp-jquery-lightbox-js-extra'>
/* <![CDATA[ */
var JQLBSettings = {"showTitle":"1","showCaption":"1","showNumbers":"1","fitToScreen":"1","resizeSpeed":"400","showDownload":"1","navbarOnTop":"0","marginSize":"0","slideshowSpeed":"4000","prevLinkTitle":"previous image","nextLinkTitle":"next image","closeTitle":"close image gallery","image":"Image ","of":" of ","download":"Download","pause":"(pause slideshow)","play":"(play slideshow)"};
/* ]]> */
</script>
<script type='text/javascript' src='https://etvnews.com/wp-content/plugins/wp-jquery-lightbox/jquery.lightbox.min.js?ver=1.4.8.2' id='wp-jquery-lightbox-js'></script>
<script type='text/javascript' src='https://etvnews.com/wp-includes/js/wp-embed.min.js?ver=026b79e0a0da26819c91fce8557b05fe' id='wp-embed-js'></script>
</body>
</html>